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 Overview Chapter1.
1.1. Specification 

 

CODESYS PLC with IIoT Gateway 

Features 
 CODESYS PLC compliant with IEC61131-3 

 Fan-less Cooling System 

 Built- in 4GB Flash Memory and RTC 

 SD Card Slot Supports SD/SDHC Cards 

 Rich combination of iR Series Modules 

Gateway 

 COM2 / COM3 RS-485 2W Supports MPI 187.5K 

 Supports OPC UA Server/Client and MQTT 
 Modbus TCP/IP Gateway 

Memory 

Flash 4 GB 

RAM 512 MB 

Data, Memory, Code 3 MB 

Retain area 16 KB (every minute) (Kept after reboots) 

Persistent area 16 KB (every minute) (Kept after downloads) 

File system 8MB 

Processor  Dual-Core 32 bits RISC 1GHz 

I/O Port 

SD Card Slot SD/SDHC 

Ethernet 
Ethernet 1: 10/100/1000 Base-T x 1 

Ethernet 2: 10/100 Base-T x 1 

COM Port 
COM1 RS-232 2W, COM2 RS-485 2W/4W,  

COM3 RS-485 2W 
Local bus iBus 

CAN Bus N/A 

CODESYS 
Protocol Modbus TCP/IP Master, EtherCAT Master 

Max. Number of iR Module 16 

RTC  Built-in 

Power 

Input Power 24±20%VDC 

Power Isolation Built-in 

Power Dissipation Nominal 310mA＠24VDC 

Current for Internal Bus Max 2A＠5VDC 

Current Consumption 550mA＠5VDC 

Voltage Resistance 500VAC (1 min.) 

Isolation Resistance Exceed 50M @ 500VDC 

Vibration Endurance 10 to 25Hz (X, Y, Z direction 2G 30 minutes) 

Specification 

PCB Coating Yes 

Enclosure Plastic 

Dimensions WxHxD  50 x 109 x 81 mm 

Weight Approx. 0.24 kg 

Mount 35 mm DIN rail mounting 

Environment 

Protection Structure IP20 

Storage Temperature -20° ~ 70°C (-4° ~ 158°F) 

Operating Temperature -10° ~ 50°C (14° ~122°F) 

Relative Humidity 10% ~ 90% (non-condensing) 

Certificate 
CE CE marked 

UL cULus Listed 

Software  
EasyBuilder Pro V6.03.02 or later versions 

CODESYS V3.5 SP10 Patch 3 or later 
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1.2. Dimensions 

 

 

a RUN/STOP switch e Ethernet 1 

b Reset Button f Ethernet 2 

c 

COM1: RS-232, 

COM2: RS-485 2W/4W, 

COM3: RS-485 2W 

g SD Card Slot 

d Power Connector h Expansion Connector 

 

  

英文版 簡中版 日文版

81mm [3.19"]

1
0

9
m

m
 [

4
.2

9
"]

50mm [1.97"]

a
b

c

d

f

e

g

h

Top View

Side ViewFront ViewSide View

Bottom View

81mm [3.19"]

1
0

9
m

m
 [

4
.2

9
"]

h

81mm [3.19"]

1
0

9
m

m
 [

4
.2

9
"]

h

50mm [1.97"]

a
b

c

d

f

e

g

50mm [1.97"]

a
b

c

d

f

e

g



cMT-CTRL01 User Manual 
 

 3 

1.3. Pin Assignment 

COM1 [RS232], COM2 [RS-485 2W/4W], COM3 [RS-485 2W], 9 Pin, Male, D-sub 

PIN# 
COM1 

[RS-232] 

COM2 [RS-485] COM3 

[RS-485] 2W 2W 4W 

1    Data+ 

2 RxD    

3 TxD    

4    Data- 

5 GND 

6  Data+ Rx+  

7  Data- Rx-  

8   Tx+  

9   Tx-  

 

1.4. Restoring factory default 

Press and hold on the Reset button on the unit for more than a certain period of time when the 

RUN/Stop toggle switch (CODESYS switch) is in STOP state:  

 

Period of time 

button is pressed 

ERR LED Action 

0~3 seconds  No action. 

3~10 seconds Blinking Reboot PLC and Gateway 

Over 10 seconds Lights UP Reset to default. The projects stored in the unit will be cleared and Ethernet 

1, Ethernet 2 are reset to default. 

 

Default settings of cMT-CTRL01: 

Ethernet 1: DHCP, CODESYS 

Ethernet 2: DHCP, Gateway 

Note: The projects and data stored in the unit will all be cleared after restoring factory default, 

please download the projects again. 

 

1.5. LED indicator 

LED indicators show the status of cMT-CTRL01. 

 
 

L.V LED 

L.V LED State Description 

OFF 24V power normal 

Blinking Detect 24V power 

ON 24V power error 
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CPU LED 
Green(RUN)  Red(ERR)  Description 

OFF OFF CODESYS STOP 

ON OFF CODESYS RUN 

Blinking OFF EBPro or CODESYS scans and the LED of the found unit 
winks. 

OFF ON CODESYS ERROR 

Blinking Blinking BOOT 

 

IO LED 
Green(RUN)  Red(ERR)  Description 

OFF OFF Power off or no power 

Fast Blinking OFF CODESYS stops 

Blinking OFF IO initiating 

Blinking ON IO initiation error 

ON OFF IO working 

ON Blinking IO module alarm 

ON ON IO communication fault 

Blinking Blinking Exceeds power limitation or too many modules 
connected. 

 

Ethernet 

 

Ethernet 1: Assigned for CODESYS by default; and the default IP is DHCP.  

If a DHCP server is not available, the IP address will be set to 0.0.0.0. 

Ethernet 2: Assigned for Gateway; and the default IP is DHCP.  

If a DHCP server is not available, the IP address will be automatically set to 169.254.0.1. 

 
Color  Status 

Orange Ethernet connection status 

Green 
Ethernet communication 
status 

 

1.6. Battery 

cMT-CTRL01 requires a CR1220 3V lithium battery to keep the RTC running. 

Battery Specification: UL Certification Battery, Type CR1220, Rated 3V, Max. Abnormal Charging 

Current 10mA, Working Temperature: max. 70°C 

Battery replacement shall be performed by qualified personnel (Engineer) only and care must be 

taken when handling lithium batteries. For more information on battery replacement and disposal 

considerations, please refer to the following link:  
http://www.weintek.com/download/MT8000/eng/FAQ/FAQ_103_Replace_Battery_en.pdf 

http://www.weintek.com/download/MT8000/eng/FAQ/FAQ_103_Replace_Battery_en.pdf
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1.7. Power connection 

Power: The unit can be powered by DC power only, the voltage range is compatible with most 

controller DC systems. The power conditioning circuitry inside the unit is accomplished by a 

switching power supply. The peak starting current can be as high as 500mA. 

cMT-CTRL01 voltage range: 24±20% VDC 

Power Connector Specifications:  

Wire AWG: 24~12 

Wiring Conductor Minimum Temperature: 75°C 

Screw Torque: 4.5 lbf-in (max.) 

Copper conduct only 

 
Note: Connect positive DC line to the '+' terminal and the DC ground to the '-' terminal. 

 

1.8. Power Consumption 
Type Device Consumption(5V)  Power Supply(5V) 

CPU cMT-CTRL01 550mA/2.75w 2A/10w 

Digital I/O 

iR-DM16-P 130mA/0.65 W -- 

iR-DM16-N 130mA/0.65 W -- 

iR-DQ08-R 220mA/1.1 W -- 

iR-DQ16-N 205mA/1.02 W -- 

iR-DQ16-P 196mA/0.984 W -- 

iR-DI16-K 83mA/0.418 W -- 

Analog I/O 

iR-AQ04-VI 65mA/0.325 W -- 

iR-AI04-VI 70mA/0.35 W -- 

iR-AM06-VI 70mA/0.35 W -- 

iR-AI04-TR 65mA/0.325 W -- 

Motion iR-PU01-P 108mA/0.54 W -- 

 

Note: 

cMT-CTRL01 is the only power supply for the modules in this system. Please consider power requirements when connecting 

multiple modules. The following is an example. 

 

Device Name Consumption Power Supply 

CPU cMT-CTRL01 550mA/2.75w 2A/10w 

Module iR-DM16-P *11 130mA*11=1.43A X 

System Power consumption ∶ 550mA + 1.43A = 1.98 A   

Power supply: 2A > 1.98A 

 

The following Excel file can be used for calculating the current: 

https://dl.weintek.com/public/iR/Utility/iR_Current_Calculation_eng.xlsx 

https://dl.weintek.com/public/iR/Utility/iR_Current_Calculation_eng.xlsx
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 cMT-CTRL01 System Setting Chapter2.
Connect cMT-CTRL01’s Ethernet 2 via Ethernet cable, and then configure system settings by the 

following ways.  

 

2.1. Search for cMT-CTRL01’s IP address 

Launch Utility Manager. On the top-left menu select IIoT Gateway Series, and then select a function 

from Reboot, Download, or Upload. cMT-CTRL01 can be found in the IP/HMI Name group box by 

using the model’s IP address, even if the PC or laptop is not on the same network. Utility Manager 

can find and change cMT-CTRL01’s IP address. The following settings can be carried out after 

obtaining the IP address. 

 
 

2.2. Set in internet browser 

Open internet browser (IE, Chrome, Firefox, Safari), and enter cMT-CTRL01’s IP address (e.g. 

192.168.100.1) to configure cMT-CTRL01.  
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cMT-CTRL01 system information is shown in the Login page, and the language used can be changed 

in this page. 

Icon Description 

 

Displays HMI name. 

 

Displays system date. 

 

Displays system time. 

Please note that by default, Ethernet 2 is assigned for Gateway (DHCP). 

 

2.3. System Setting 

The following part introduces cMT-CTRL01 system settings. 
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Three levels of privileges can be found:  

[System Setting]: Controls all the settings  

[Update]: Controls limited items.  

[History]: Downloads history data (Recipes and Event Logs). 

 

2.3.1. Network 

Configure Ethernet ports: IP, Mask, Gateway, and DNS. 

cMT-CTRL01 is equipped with dual Ethernet ports that can be freely assigned as one of the 

following: 

1. One Ethernet port for CODESYS (Ethernet 1, DHCP) and the other one for IIoT Gateway 

(Ethernet 2 DHCP). 

2. Both Ethernet ports for IIoT Gateway 

Select [Enable CODESYS login] to log in using Ethernet 2’s IP address in CODESYS. 

 
2.3.2. Date/Time 

Set RTC date and time. Select [Sync. with host] and then click [Save] to synchronize cMT-CTRL01 

time with the computer time. 
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2.3.3. HMI Name 

Enter a name to identify the unit. 

[Identification light]: The LED indicator of the unit will flash three times when this button is clicked, 

helping user to find the unit. 

 
2.3.4. History 

This tab offers settings related to historical data. 

[Clear]: Clears history data. 

[Backup]: Downloads history data in the unit to this computer. 
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2.3.5. Email 

This tab offers settings related to email. 

[SMTP]: Configure email server and relevant settings. 

[Contacts]: Set email contacts in this tab. 

[Update Email Contacts]: Import the email contacts built using Administrator Tools. 

 

2.3.6. Project Management 

This tab offers settings related to project management. 

[Restart Project]: Restart cMT-CTRL01 project. 
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[Update Project]: Upload the project’s *.cxob file to cMT-CTRL01. 

[Backup Project]: Backup the project file to this computer.  

[USB/SD Update]: Use the project file stored in the external device to update the project file on 

cMT-CTRL01. 

 
2.3.7. System Password 

Set login password and the password for transferring project file. 

 

2.3.8. Enhanced Security 

The account settings in this tab determine the accounts that can log in OPC UA. 

[Accounts]: Add user or change user password and operable classes. 

[Import User Account]: Import the user accounts built in Administrator Tools. 
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2.3.9. EasyAccess 2.0 (Optional) 

This tab shows Hardware Key, EasyAccess 2.0 activate status, and proxy settings. 

For more information on EasyAccess 2.0, please see EasyAccess 2.0 User Manual.  

 
2.3.10. OPC UA 

Configure OPC UA settings. Please see “Chapter 6 OPC UA Web Management Interface” in this 

manual for details.  

 

2.3.11.  Communication 

This tab displays the communication parameters of the device connected to cMT-CTRL01, and the 

parameters can be changed in this tab. 
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Parameters that can be viewed and modified for a device connected via COM port. 

Interface 

Baud rate 

Data Bits 

Parity 

Stop Bits 

Timeout 

Parameter 1 

Parameter 2 

Send ACK Delay 

Parameters that can be viewed and modified for a device connected via Ethernet. 

IP Address 

Port 

Timeout 

Turnaround Delay 

Parameter 1 

Parameter 2 

Send ACK Delay 
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 Updating Web Package and OS Chapter3.
cMT-CTRL01 Web Package and OS can be updated through Ethernet. Launch Utility Manager, select 

[Gateway Series] » [Maintenance] » [cMT-Gateway OS Update]. 

 

3.1 Updating Web Package 

1. Select an HMI to update OS. 

2. Select [Web package] and browse for the source file. 

3. Click [Update]. 

 
 

3.2 Updating OS 

1. Select a cMT-CTRL01 to update OS. 
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2. Select [OS], a Warning message shows, please read this message carefully before you click [OK]. 

 

3. If you click [OK], the cMT-Gateway OS Update window opens again, browse for the source file, 

and then click [Update]. 

 

4. The message window below opens, please do not turn off the power while upgrading. 

 

5. When finished, cMT-Gateway OS Update window shows “finished”. 
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3.3 Updating iR Firmware 

When updating iR firmware for cMT-CTRL01, please press and hold the Reset button and power up 

the unit again. 

1. Select a cMT-CTRL01. 

 
2. Select the bin file and then click [Update]. 
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After update, power up the unit again. 

 

In CODESYS log in cMT-CTRL01, and the iR firmware version can be found in the iBus tab. 
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 How to create a cMT-CTRL01 project Chapter4.
 

This chapter explains how to create a project when cMT-CTRL01 is used as an OPC UA Server. The 

basic steps are: 

1. Add a driver into Device List in EasyBuilder Pro. 

2. Enable OPC UA Server and designate communication address. 

3. Download the project to HMI. 

 

The following explains how to set up OPC UA Server in the project. 

 

4.1. Create a new project 

Step 1. Launch EasyBuilder Pro and select a cMT-CTRL01. 

 
Step 2. Add a device into the list and configure communication parameters.  
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Step 3. Click [IIoT/Energy] » [OPC UA Server], and select [Enable] check box to enable OPC UA 

Server. 

 

 

Step 4. Click [Tags] of the device and then click [New Tag] to add tags monitored using OPC UA. 

When finished, click [OK] to leave. 

 

Step 5. Find the created tags in OPC UA Server window. When a large number of tags are used, 

the tags can be exported as a csv/excel file to be edited and then imported again. 

 
 

4.2. Download project to cMT-CTRL01 

The format of the project file run on cMT-CTRL01 is *.cxob. In EasyBuilder Pro, click [Project] » 
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[Compile] to compile the project into *.cxob format. When finish compiling, you can download the 

project to cMT-CTRL01 by two ways. 

Way 1: Download using EasyBuilder Pro. Click [Project] » [Download(PC->HMI)], and set HMI IP 

address. The project can be downloaded via Ethernet. 

 

Way 2: Download using website. Open internet browser (IE, Chrome, Firefox), enter cMT-CTRL01’s 

IP address (e.g. 192.168.100.1), click System Setting, enter password, and then configure 

cMT-CTRL01 settings. Go to [Project Management] page and open [Upload Project] tab to 

download the project file from the computer to cMT-CTRL01. 
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4.3. Monitoring OPC UA Client 

After downloading the project file, use OPC UA Client software to connect with cMT-CTRL01 to 

monitor PLC data. 

 
Note: The above is a screenshot of UaExpert. For more information on OPC UA Client software 

settings, please see OPC UA server manual. 

 

4.4. On-line/Off-line Simulation 

Running On-line or Off-line simulation in EasyBuilder Pro helps you examine OPC UA Tag settings. In 

On-line simulation, cMT Gateway Viewer can read from / write to PLC. Please note that On-line 

simulation is limited to 10 minutes. 

Step 1. In EasyBuilder Pro click [Project] » [On-line Simulation] / [Off-line Simulation] to open 

cMT Gateway Viewer window. 

Step 2. Add the tags to be previewed into the Monitor list on the right side. 
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Step 3. In On-line Simulation, data in PLC tags will also change. 
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 Functions supported by cMT-CTRL01 Chapter5.
 

 OPC UA Server 

UM016009E_OPC_UA_UserManual_en.pdf 

 EasyAccess 2.0 (Optional) 

UM016001E_EasyAccess2_UserManual_eng.pdf 

 Modbus TCP/IP Gateway 

Chapter_37_MODBUS_TCP_IP_Gateway.pdf 

 OPC UA Client 

 MQTT Server / MQTT Subscriber / MQTT Publisher 

 Administrator Tools 

 Time synchronization (NTP) 

 Macro 

 Project protection 

 iE/XE/eMT/mTV communication protocol 

 Pass-through 

 Data Transfer (Global) object 

 Off-line / On-line Simulation 

 Recipes (RW, RW_A) 

 Data Sampling (please note that data visualization is not supported, including Trend Display, 

History Data Display, and so on.) 

 Event Log (please note that data visualization is not supported, including Alarm Bar, Alarm 

Display, and so on.) 

 Database Server 

 E-Mail 

 Scheduler 

 Web interface for managing OPC UA and communication parameters 

  

https://dl.weintek.com/public/Document/UM0/UM016009E_OPC_UA_UserManual_en.pdf
https://dl.weintek.com/public/Document/UM0/UM016009E_OPC_UA_UserManual_en.pdf
https://dl.weintek.com/public/EasyAccess20/Manual/UM016001E_EasyAccess2_UserManual_eng.pdf
https://dl.weintek.com/public/EasyAccess20/Manual/UM016001E_EasyAccess2_UserManual_eng.pdf
https://dl.weintek.com/public/EBPro/UserManual/eng/UserManual_separate_chapter/Chapter_37_MODBUS_TCP_IP_Gateway.pdf
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 OPC UA Web Management Interface Chapter6.
 

6.1. Introduction 

cMT-CTRL01 provides a web-based tool for convenient access to OPC UA configurations.  

 
 

Open cMT-CTRL01’s webpage by entering its IP address into the address bar of a web browser. At 

the entry page, log in with System setting’s password. Factory default of the password is 111111. 

(Suggested resolution: 1024×768 or higher) 

 

Navigate to the OPC UA configuration page from the context menu on the left. 

The OPC UA configuration page consists of a Startup/Shutdown control with status bar and tabbed 

windows including: Server settings, Edit node, Certificates, Discovery, and Advanced. 

 



cMT-CTRL01 User Manual 
 

 26 

Usage of each window tab: 

 

Tab Description 

Server settings 
Configure server settings such as port, name, security, user 

authentication……etc. 

Edit node Manage tags used by OPC UA server. 

Certificates Manage certificates used by OPC UA server. 

Discovery Manage list of discovery server. 

Advanced Advanced options and features. 

 

6.2. Startup / Shut Down 

 

 

Use the toggle button to start up or shut down the OPC UA server. If there is active client 

connection, when shutting down, the server will wait for a few seconds before closing off 

completely. 

 

In addition, both the toggle button and a line of text also indicate the status of the server. The status 

is refreshed approximately every 10 seconds. An icon on the right  indicates that the status is 

being refreshed.  

 

Endpoint URL is also displayed for user’s reference. 

 

*Whenever a page refresh is desired, use the menu on the left. Avoid using the browser’s refresh 

button to reload a tab as you may be asked to enter the password to log in again. 

 

6.3. Server Settings 

The Server settings page shows general configurations of the OPC UA server. 
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General Function 

Port Access port of the OPC UA server 

Server name Server name of the OPC UA server 

Security policy 

Supported security policies. At least one must be selected. 

Supported Policy: None, Basic128Rsa15, Basic256, Basic256sha256 

Mode: Sign, Sign & Encrypt 

Option 
Automatically Trust all client certificates: by enabling this option, the 

OPC UA server will trust the certificate from any client connection. 

 

OPC UA server must be configured with at least one user authentication mode as listed in the 

following table. 

 

Authentication Descriptions 

Anonymous 
Allow anonymous client connection. At least one of Browse, Read, or 

Write modes must be selected. 

User name & 

Password 

Allow user authentication with username and password. Each access 

mode, browse, read, and write can be assigned to a user class. User 

classes are configured in the Enhanced Security mode on the web 

interface or in EasyBuilder Pro. 

Certificate User authentication with X.509 certificate 
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After completing settings, click the Save button to save the changes. OPC UA server will shut down 

momentarily and then restart for the changes to take effect. 

 

6.4. Edit Node 

 
 

In this page, the user can view and manage the tags currently available in the OPC UA server. New 

nodes and groups can be added, while existing nodes and groups can be edited or deleted. For ease 

of navigation, detail information of the currently selected node/group is displayed on the right.  

After completing settings, it is necessary to click the Save button to save the changes. OPC UA 

server will shut down momentarily and then restart for the changes to take effect. Changes will be 

lost if one exits this page without saving. 
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Note that all modifications can only be made for existing drivers. It is not possible to change or add 

other drivers that are not already available. It is also not possible to edit the nodes used by tag 

PLCs*. 

 

*Tag PLCs are characterized by their use of name tags as device memory address as opposed to 

using device name with indices. Examples of tag PLCs include: BACnet, Rockwell Free Tag Names , 

Siemens S7-1200/1500 Symbolic Addressing,…etc. 

 

6.5. Certificates 

In this page, the user can manage certificates and revocation lists of the OPC UA server. Use the 

dropdown menu to access each page. 

 

If “Automatically Trust All Client Certificates” (in the Server settings tab ) option is not enabled, OPC 

UA server will reject all client connections and place their certificates in the untrusted list. User may 

manually “trust” them in this page. Use the reload button  to repopulate the list of certificates if 

necessary. 

 

Similarly, currently trusted certificates can be manually rejected on the same page.  
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Page Description 

Trusted Clients 
Lists of trusted/rejected client certificates on the server.  

Supported operation: Trust/Reject, Remove, Import, Export. 

Trusted Users 
Lists of trusted/rejected user certificates on the server. Supported 

operation: Trust/Reject, Remove, Import, Export. 

Own 

Server’s own certificate.  

Supported operation: Update, Remove. 

When updating own certificate, matching certificate and Private Key 

must be uploaded together; otherwise, update will fail. 

A self-signed, 20-year validity certificate will be generated 

automatically if own certificate is absent when server starts up. 

Trusted Client 

Issuers 

List of trusted client issuer certificates. 

Supported operation: Import, Remove, Export. 

Trusted User 

Issues 

List of trusted client issuer certificates. 

Supported operation: Import, Remove, Export. 

Certificate 

Revocation List 

Certificate revocation lists for client, user, client issuer, and user issuer. 

Supported operation: Import, Remove, Export 

 

6.6. Discovery 

OPC UA server can register itself with Local Discovery Servers. In this page, the user can maintain 

the list of discovery servers that OPC UA server will register with during startup. Should the 

discovery server be unavailable during server shutdown, the shutdown process will be slightly 

delayed. 
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After completing settings, click the Save button to save the changes. OPC UA server will shut down 

momentarily and then restart for the changes to take effect. 

 

6.7. Advanced 

Additional settings can be configured in the Advanced tab. The user can set the trace logging level 

and specific startup behavior of the OPC UA server. Furthermore, the trace log can be downloaded. 

 

 

After completing settings, click the Save button to save the changes. OPC UA server will shut down 

momentarily and then restart for the changes to take effect. 
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 Installing Weintek CODESYS and RemoteIO Package Chapter7.
Installing Weintek CODESYS and Remote IO Package allows users to easily create a cMT+CODESYS 

project in CODESYS software. Please find the Package file we prepared and follow these steps for 

quick installation. 

1. Firstly, get a copy of Weintek CODESYS and RemoteIO Package file. 

 

2. On your PC, right-click the mouse button and select [Open with CODESYS Package 

Manager]. 

 

3. Select Complete Setup or Typical Setup (you may select any of these setup types since the 

components used by Weintek Built-in CODESYS exist in both types.) 

 
4. Click [Next] when seeing the following message. 
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5. The installed component will be shown in the installation summary. 
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 Connecting cMT-CTRL01 CODESYS Chapter8.
8.1. Connecting Through Network 

The PC can directly connect with CODESYS via Ethernet 1 when: 

 The PC and cMT-CTRL01’s Ethernet 1 & 2 are all connected to the same router. 

 The PC is directly connected to cMT-CTRL01’s Ethernet 1 using an Ethernet cable. 

When the PC is connected to cMT-CTRL01’s Ethernet 2, please follow the setting steps below.  

1. Find cMT-CTRL01’s IP address in the way explained in Chapter 2.1.  

2. Open internet browser (IE, Chrome, Firefox, Safari), enter cMT-CTRL01 Gateway IP 

address (e.g. 192.168.100.1), and then configure cMT-CTRL01 settings. 

3. Open CODESYS page to see the IP address. By default DHCP is used for cMT-CTRL01 

CODESYS IP. 

 
4. When Ethernet 1 is assigned for Gateway, please see Chapter 2.3.1 Network and select 

[Enable CODESYS login]. With this option selected, Ethernet 2’s IP address can be entered 

in CODESYS for login. 

 
8.2. Creating CODESYS Project 

1. Launch CODESYS V3.5 and click [File] » [New Project], and then select [Standard project]. 

Enter the project name in Name filed, browse for the location, and then click [OK] to 

leave. 
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2. Select cMT-CTRL. CODESYS software provides 6 languages that can be selected in 

[PLC_PRG in:] drop-down list as shown below. Structure Text (ST) is used as an example in 

this manual. 

 
3. Double-click on Device (cMT-CTRL) to open the settings window. 
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4. Open Scan Network tab, CODESYS software will start searching for the CODESYS devices 

on the same network. Select the desired device and then click [OK] to leave. The last two 

IP address parts (between dots) are converted into HEX digits and shown in this window. 

For example, if the IP address of the CODESYS device is 192.168.2.118, please select HMI 

Name[0276]. After clicking Wink button, CPU RUN LED flashes for three times. 

 
5. The project will connect the selected device. 
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IP address of the device can be entered in the field shown below. 
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 Creating EasyBuilder Project Chapter9.
*Please use EasyBuilder Pro v6.03.02 or later versions. 

9.1. Creating Tags 

1. Create several tags in PLC_PRG tab and make tag “test” accumulate automatically. 

 

9.2. Exporting Tags 

1. Right-click on Application in Devices tree and then select [Add Object] » [Symbol 

Configuration], use defaults. 

 

2. Find PLC_PRG, select the variables to be exported, and then click [Build]. 

 
3. Select [Build] » [General code], the *.xml file can be found in the directory of the project. 
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9.3. Configuring EasyBuilder 

Use Weintek Built-in CODESYS driver for cMT-CTRL01 Gateway, or use CODESYS V3 (Ethernet) driver 

for other HMI models to connect with CODESYS on cMT-CTRL01. 

9.3.1. Connecting Built-in CODESYS 

1. Create a project and select Weintek Built-in CODESYS in the device list. 

 

2. Click [Import Tag] to import the *.xml file built in preceding steps. 

 

3. The CODESYS tags can now be found in Tag Manager. 

 

4. For cMT-CTRL01 Gateway, create OPA UA TAG, or use MQTT publisher.  

For other HMI models, create a Numeric object and use “Application.PLC_PRG.test” for 

address. After downloading the project to HMI, “test” tag data can be found. 
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9.3.2. Connecting cMT-CTRL01 CODESYS to other HMI 

1. Create a project and select CODESYS V3 (Ethernet) driver in the device list. 

 

2. Click [Import Tag] and select the *.xml generated in the preceding steps. 

 

3. CODESYS Tag can be found after import. 
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 Connecting cMT-CTRL01 CODESYS to iR Series Modules Chapter10.
 

cMT-CTRL01 and iR Series modules do not support hot swapping by design. Please connect iR Series 

modules to cMT-CTRL01 before powering up cMT-CTRL01. 

1. Right-click on [iBus (iBus)] and then select [Add Device]. 

 

2. Select an iR module and then click [Add Device]. 

 

3. The added device can be found under iBus. You may add more modules with this window 

is left opened. 
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4. Double click on a module name to open iROption I/O Mapping. 

 
Analog modules, other modules, and their settings. 

 
iBus has two addresses in BYTE type that show low voltage and I/O error. 

 

5. Open PLC_PRG in Devices tree and configure variables as shown below. 

 

6. In Devices tree double click on an iR module name to open object settings window. In 
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iROption I/O Mapping tab, select a variable for the object. 

 

7. When finished, click [Online] » [Login] to download the project to CODESYS. 
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 Connecting cMT-CTRL01 to iR-ETN Chapter11.
11.1. Connecting cMT-CTRL01 to iR-ETN using Modbus TCP/IP 

1. Right-click on Device (cMT-CTRL01) and then select [Add Device]. 

2. Select [Ethernet Adapter] » [Ethernet] and then click [Add Device]. 

 

3. Ethernet (Ethernet) can be found in Devices tree. 

 

4. Double-click on Ethernet with the current window opened in Devices tree or right-click on 

Ethernet and then select [Add Device]. 

5. Click [Fieldbusses] » [Modbus] » [Modbus TCP Master] » [Modbus TCP Master], and then 

select [Add Device]. If you have the PLCopenXML exported from EasyRemotIO, click 

[Project] » [Import PLCopenXML…] to import the file to complete the settings. 

 

6. Double-click on Modbus TCP Master with the current window opened in Devices tree or 

right-click on Modbus TCP Master and then click [Add Device]. 
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7. Click [Fieldbusses] » [Modbus] » [Modbus TCP Slave] » [Modbus TCP Slave], and then 

select [Add Device]. 

 

8. Double click on Ethernet in the Devices tree, enter CODESYS’s IP address in General tab, 

and then select [Change Operating System Settings]. When [Use operating System 

Settings] is selected, settings on cMT-CTRL01 will be used without being changed. 

 

9. When CODESYS is already connected, go to General tab and click the […] button near 

Interface field and select eth0. 

 
10. Select Modbus_TCP_Slave in the Devices tree and then go to General tab to set up 

IR-ETN’s IP address and Unit ID. 
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11. Open [Modbus Slave Channel] tab and create Modbus Variable. 

 

 

12. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write a command as 

shown below. 
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13. Open Modbus_TCP_Slave in Devices tree and then go to [Modbus_TCPSlave I/O Mapping] 

tab to set up iR-ETN’s IP address and Unit ID. 

 

14. When finished, click [Online] » [Login] to download the project to CODESYS. 

11.2. Connecting CODESYS and Modbus TCP/IP Gateway 

cMT-CTRL01 supports Modbus TCP/IP Gateway which allows CODESYS to access Modbus TCP/IP 

Gateway using Modbus TCP Slave, in order to control the devices connected to Modbus TCP/IP 

Gateway. 

 
11.2.1. CODESYS Settings 

On cMT-CTRL01, Gateway and CODESYS respectively use different IP addresses; therefore, by 

adding Modbus_TCP_Slave for CODESYS and set IP address to 10.255.255.1, CODESYS is able to 

connect to Modbus Gateway. 
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To immediately display CODESYS data on HMI, values can be written to HMI’s LW registers for 

objects to read. When setting Modbus Slave Channel, Cycle Time can be configured to adjust the 

frequency at which data is written to the registers. 

 

11.2.2. Gateway Settings 

For more information on Modbus Gateway, please see EasyBuilder Pro User Manual Chapter 37 

MODBUS TCP IP Gateway.  

  

https://dl.weintek.com/public/EBPro/UserManual/eng/UserManual_separate_chapter/Chapter_37_MODBUS_TCP_IP_Gateway.pdf
https://dl.weintek.com/public/EBPro/UserManual/eng/UserManual_separate_chapter/Chapter_37_MODBUS_TCP_IP_Gateway.pdf
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 Connecting cMT-CTRL01 via EtherCAT Chapter12.
From CODESYS Firmware 20200401, cMT-CTRL01 supports EtherCAT connection. Please see Chapter 

14.2 Questions relating to Downloading cMT CODESYS File, and Chapter 7 Installing Weintek 

CODESYS and RemoteIO Package in this manual for more information. 

 

This chapter explains how to connect cMT-CTRL01’s LAN1 to iR-ECAT and iR module.  

 

Open the CODESYS project file of cMT-CTRL01 and add a device. The recommended device is 

EtehrCAT Master V3.5.12.0. This device can be found when [Disaply all versions (for expert only)] is 

selected. 
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After adding the device, select cMT-CTRL01. Double click on EtherCAT Master, click [Browse…], and 

select network adapter eth0. 

 

To set the device manually, add iR-ECAT first. iR-ECAT may have multiple versions, please select a 

suitable version. 
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Add iR I/O module. 

 

CODESYS can scan EtherCAT devices on the network. Set the device and select cMT-CTRL01. 

Right-click on EtherCAT Master and then select [Scan For Devices…]. 

 
Information on iR-ECAT and iR I/O modules is displayed in the Scan Devices window. Click [Copy All 

Devices to Project] to finish setting up the device. 
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 Removing Weintek Built-in CODESYS Chapter13.
1. Click [Tools] » [Packages Manager]. 

2. Find Weintek Built-in CODESYS and then click [Uninstall]. 

 

3. Click [Next] when seeing the window below. 

 
4. Removing the program. 

 
5. Click [Finish]. 
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 Frequently Asked Questions Chapter14.
 

14.1. Questions Related to CODESYS 

Q1. When the indicator of CODESYS Gateway lights up in red, how can I connect to the device? 

A: When CODESYS Gateway is not properly started or installed, its indicator will light up in red.  

 

Please try the following 3 methods to solve this situation. 

1. Click the icon of “CODESYS Gateway SysTray” in system settings and then click [Start 

Gateway]. 

2. Add new gateway and enter HMI IP. 

 

 

3. Re-install CODESYS Gateway. 

 

Q2. Why a triangle icon shows near Modbus_TCP_Slave device when I log in HMI in CODESYS 

software? 

 
A: This means that HMI cannot connect Modbus TCP/IP device via CODESYS. Please check the 
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IP settings and make sure the cable is properly connected. 

Q3. Which CODESYS Development System version is suitable for cMT+CODESYS? Is there any 

other version to use? 

A: Use the same version as cMT+CODESYS runtime 

The built-in CODESYS Runtime of cMT+CODESYS is 3.5.10.30; therefore, using CODESYS 

Development 3.5.10.30 is recommended. 

Download link: https://www.weintek.com/globalw/Download/Download.aspx 

Use a later version on PC 

Versions later than CODESYS Development 3.5.10.30, including 64bit versions are also 

compatible. The CODESYS Library offered by Weintek can work properly when using these 

versions. 

The current latest version of CODESYS Development is 3.5.15.20 (Date: 19/11/2019) 

Download link:  

https://store.codesys.com/codesys.html#All%20versions 

Please note that Missing Libraries issue may occur when using a new version CODESYS 

Development System to open an earlier version CODESYS project. 

The following two solutions can be used to address this issue: 

1. Click “Download Missing Libraries” in Library Manger. 

2. Use cMT+CODESYS Package (PC) 1.0.0.229 or later (1.0.0.229 is not included), select and 

install library version 3.5.10.30. 

Upgrade from CODESYS V2.3 to CODESYS V3.5  

CODESYS offers a tool for users to use CODESYS Development 2.3 project in CODESYS V3.5 

Development. Reference link: 

https://store.codesys.com/codesys-v23-converter.html 

Use compatible version for EasyRemoteIO to work with CODESYS 

By default, the PLCopen XML file exported from EasyRemoteIO can work in CODESYS 

Development System V3.5.10.0. The following two ways are options for using other versions. 

1. Set the version in EasyRemoteIO before exporting PLCopen XML. (supported by 

EasyRemoteIO V1.3.1.0 or later)  

2. Open PLCopen XML file in Windows® Notepad software, change the <Version> to the 

current version of CODESYS Development, and save to a new file. Let’s take CODESYS 

Development version 3.5.12.0 as an example:  

In Notepad, change from <Version>3.5.10.0</Version>  

to <Version>3.5.12.0</Version>. 

 

14.2. Questions Related to Downloading cMT CODESYS File 

Q1. How to update CODESYS firmware? 

A:  

There are 2 ways to update CODESYS firmware. 

https://www.weintek.com/globalw/Download/Download.aspx
https://store.codesys.com/codesys.html#All%20versions
https://store.codesys.com/codesys-v23-converter.html
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1. Launch Utility Manager and select Gateway Series » Maintenance » CODESYS Firmware 

Update. Browse for the firmware file and click [Update]. 

 

2. Enter cMT HMI’s IP address in the website browser and find [CODESYS] » [CODESYS 

update] tab. Select the file and click [Update]. 

 

 

Q2. How to download CODESYS project using website? 

A: 

1. In CODESYS software select [Online] » [Create boot application]. An *.app file and a *.crc 

file will be generated. 
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2. Enter cMT HMI’s IP address in the website browser and find [CODESYS] » [Project update] 

tab. Select the files generated in the previous step and click [Update]. 
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Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their respective 

companies. 

This document is subject to change without prior notice. 
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